Shipup - DB issue - Spike of latency – Incident details

All systems operational

DB issue - Spike of latency

Resolved
Degraded performance
Started over 3 years agoLasted about 4 hours

Affected

API

Operational from 8:24 AM to 8:24 AM, Degraded performance from 8:24 AM to 12:42 PM

Orders / Trackers

Operational from 8:24 AM to 8:24 AM, Degraded performance from 8:24 AM to 12:42 PM

Webhooks

Operational from 8:24 AM to 8:24 AM, Degraded performance from 8:24 AM to 12:42 PM

Webhook sending

Operational from 8:24 AM to 8:24 AM, Degraded performance from 8:24 AM to 12:42 PM

Updates
  • Resolved
    Resolved

    After isolating some part of the applications, the number of spikes have slowly decreased and it was eventually resolved. We will still continue to investigate to understand what causes the issue initially.

  • Update
    Update

    This issue is still under investigation. The spike occurs every 30 minutes to 1 hour and cause our database to be inaccessible for a few seconds. The application is not impacted between spikes.

  • Investigating
    Investigating

    We are currently facing issues with spike of latency in our database connections. This may lead to a partial outage in most parts of the Shipup application